29.11.2017 klo 12:20
Uutinen

Päivititkö jo uusimpaan Mac-käyttöjärjestelmään? Siitä löytyi vakava tietoturva-aukko

Applen eilen tarjolle tullutta macOS High Sierra -käyttöjärjestelmää ei vielä kannata ladata, sillä siitä on löytynyt tietoturvahaavoittuvuus.

Tuoreen käyttöjärjestelmän tietoturva-aukko mahdollistaa järjestelmään kirjautumisen pääkäyttäjän oikeuksilla yksinkertaisella keinolla, kirjoittaa muun muassa Tivi.

Käyttöjärjestelmää ei siis vielä kannata ladata koneelle. Apple on kertonut työstävänsä parhaillaan tietoturva-aukon paikkaavaa korjauspäivitystä. Haavoittuvuus ei vaikuta aikaisempiin macOS-versioihin.

Kyseinen haavoittuvuus on asiantuntijoiden mukaan vakava, sillä tunkeilija voi saada sen kautta itselleen tietokoneen pääkäyttäjän oikeudet. Erityisen suuri riski on silloin, jos haittaohjelma saa koneen pääkäyttäjän oikeudet.

Ars Technica -verkkosivuston mukaan tämä onnistuu pahimmillaan vain muutamalla yrityskerralla.

Tivin mukaan hyökkääjä voi kirjautua järjestelmään käynnistämällä koneen ja syöttämällä root-tunnuksen, jos levyn salaus ei ole käytössä. Vaikka salaus olisikin käytössä, root-käyttäjä voi kirjautua koneelle ja tehdä muutoksia asetuksiin ja poistaa salauksen.

Kyseinen toimenpide ei välttämättä toimi samalla tavalla kaikilla Mac-tietokoneilla.

Apple ohjeistaa käyttäjiä suojaamaan itsensä asettamalla uuden root-salasanan. Oletusarvoisesti salasana on järjestelmässä tyhjä. Ohje salasanan asettamiseen löytyy Applen tukisivuilta.

Kuva: Kuvakaappaus

Pauli Reinikainen

pauli.reinikainen (at) yrittajat.fi

Muita kiinnostavia aiheita